Написать программу в паскале вычислить значения функции Y=tg(sinx)+2 при...

0 голосов
37 просмотров

Написать программу в паскале вычислить значения функции Y=tg(sinx)+2 при x=0,5;0,7;0,9;…;2,1.


Информатика (21 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
  var x:=0.5;
  while x<=2.1 do begin<br>    Writeln('x=',x:3:1,' y=',tan(sin(x))+2);
    x+=0.2
    end
end.

Результат выполнения программы
x=0.5 y=2.5198809015013
x=0.7 y=2.75112025607465
x=0.9 y=2.99586604900996
x=1.1 y=3.23765167169871
x=1.3 y=3.43923041043966
x=1.5 y=3.5488600833871
x=1.7 y=3.52922062804747
x=1.9 y=3.38750383103094
x=2.1 y=3.16912357769899

(142k баллов)
0

Спасибо:)

0

Пожалуйста. Но достаточно кнопочки с сердечком.