Нужно написать программу в паскале, используя оператор цикла с постусловием repeat until....

0 голосов
42 просмотров

Нужно написать программу в паскале, используя оператор цикла с постусловием repeat until.
"Определить количество натуральных чисел, рассматривая их в порядке возрастания, сумма кубов которых не превышает 50000."


Информатика (15 баллов) | 42 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
  i, s: longint;

begin
  i := 1;
  s := 0;
  repeat
    s := s + i * i * i;
    i := i + 1;
  until s >= 50000;
  writeln(i);
end.

(13.9k баллов)
0 голосов

//////////////////////////////////

(1.7k баллов)