Написать программу ** с++ Даны три стороны одного и три стороны другого треуголь- ника....

0 голосов
60 просмотров

Написать программу на с++
Даны три стороны одного и три стороны другого треуголь-
ника. Эти треугольники равновеликие, т.е. имеют равные
площади.


Информатика (268 баллов) | 60 просмотров
0

Нужно проверить их равновеликость, так?

0

Я приведу прогу, считая, что подразумевалось именно это

Дан 1 ответ
0 голосов

#include
#include
using namespace std;
double eps = 0.000001;
double sq(double a, double b, double c)
{
   double p = (a + b + c) / 2;
   return sqrt(p * (p - a) * (p - b) * (p - c));
}
int main() 
{
   double a1, b1, c1, a2, b2, c2;
   cin >> a1 >> b1 >> c1 >> a2 >> b2 >> c2;

   if (sq(a1, b1, c1) >= sq(a2, b2, c2) - eps && sq(a1, b1, c1) <= sq(a2, b2, c2) + eps)</span>
      cout << "YES";</span>
   else

      cout << "NO";<br>
}

(9.5k баллов)