Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в...

0 голосов
114 просмотров

Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел
(массив не использовать).
Использовать только Repeat
программа ПАСКАЛЬ
40 БАЛЛОВ


Информатика (62 баллов) | 114 просмотров
0

( k/10 )

0

надо было во вритлн написать что якобы среднее арифметическое = там например 17 

0

var m,i,l:longint; k,n:real; begin repeat  readln(n);  k:=k+n;  inc(i); until i>9; writeln(k/10:0:0);readln;end.

0

а так?

0

либо в врителн без :0:0

0

Вообще переменные i и k надо бы инициализировать:) 

0

вообщем закосячил я здесь)))

0

да без 0 0 надо вроде 

0

ну ка надо переделывать 

0

не рабит 

Дано ответов: 2
0 голосов
Правильный ответ

Var
i: integer;
sr, s, x: real;
begin
i:=0;
repeat
readln(x);
s:=s+x;
i:=i+1;
until i=10;
sr := s/10;
writeln(sr);
end.

(15.5k баллов)
0

x-то тоже real должен быть

0

)))

0

Беда с вами) Тогда и s тоже)

0

да да , вот че среднее выводит вритон 

0 голосов

Var i, n: integer;
S, k: real;
begin
  n := 10;

  S := 0;

  repeat

    writeln('Print number');

    readln(k);

    S := S + k;

    n := n - 1;

  until n = 0;

  writeln(S / 10);
end.

(9.5k баллов)