Напишите программу которая вычисляет сумму 1) Первыз n натуральных чисел 2) квадратов...

0 голосов
94 просмотров

Напишите программу которая вычисляет сумму
1) Первыз n натуральных чисел
2) квадратов первых n натуральных чисел
3) Всех четных чисел в диапазоне от 1до n
4) всех двузначных чисел


Информатика (91 баллов) | 94 просмотров
0

Какой язык программирования?

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET
var i,n,s1,s2,s3,s4:integer;
begin
  readln(n);
  for i:=1 to n do begin
    s1:=s1+i;
    s2:=s2+i*i;
    if i mod 2=0 then s3:=s3+i;
    if (i>9) and (i<100) then s4:=s4+i;<br>  end;
  writeln(s1,' ',s2,' ',s3,' ',s4)

end.

(13.9k баллов)