Программирование циклов : Составьте программу по которой компьютер десять раз запросит...

0 голосов
87 просмотров

Программирование циклов :
Составьте программу по которой компьютер десять раз запросит ввод целых чисел и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных

В ПАСКАЛЕ С ИСПОЛЬЗОВАНИЕМ WHILE или REPEAT или FOR только без скобок квадратных , дам 40 БАЛЛОВ


Информатика (62 баллов) | 87 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
i, k, x: integer;
begin
k:=0;
for i:=1 to 10 do
begin
readln(x);
if x mod 2 = 0 then //если x четный
inc(k); //увеличиваем k на 1
end;
writeln('Четных: ', k);
writeln('Нечетных: ', 10-k);
end.

(15.5k баллов)
0

inc(k); //увеличиваем k на 1 как можно обойти эту строку 

0

и можно ли сделать не через иф мод а через to do 

0

вместо inc(k) написать k:=k+1;

0

if mod проверяет кратность. while to do - цикл, можно заменить фор, только смысла нет. Тем более в задании "WHILE или REPEAT или FOR", то есть одно из трёх.

0

 //если x четный , как можно записать по другому эту фразу , через вритлн ? или как , чтобы не было ////

0

//если x четный - это комментарии, чтобы вам было понятно что тут происходит. "//если x четный" и "//увеличиваем k на 1" можно убрать вообще

0

спасибо, побольше бы таких как , ты ведь главное не списать , а понять