Составить программу в паскале которая вычисляет день недели по...

0 голосов
49 просмотров

Составить программу в паскале которая вычисляет день недели по номеру(1-понедельник,2-вторник...) , и говорит рабочий он или нет ( воскресенье нерабочий только ) Спасибо=)


Информатика (150 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var
a: integer;
begin

readln(a);
case a of
1: writeln('Понедельник');
2: writeln('Вторникк');
3: writeln('Среда');
4: writeln('Четверг');
5: writeln('Пятница');
6: writeln('Суббота');
7: writeln('Воскресение')
end;
if a = 7 then
write('Нерабочий')
else
write('Рабочий')

end.

(807 баллов)