Добрые люди, помогите, пожалуйста, сделать задачи по информатике. 1. Напишите программу,...

0 голосов
47 просмотров

Добрые люди, помогите, пожалуйста, сделать задачи по информатике.
1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 3.
2. Напишите программу, которая в последовательности натуральных чисел определяет количество всех нечётных чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 7.


Информатика (12 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Решение 1-й задачи:
//PascalABC.Net
//NaaMan
var
    i, n : integer;
begin
    i := 0;
    repeat
        write('Введите число > ');
        readln(n);
        if (n > 0) then
            if (n mod 2 = 0) then
                if (n mod 3 = 0) then i := i + 1;
    until (n = 0);
    writeln('Количество чётных чисел, кратных 3: ', i)
end.

Для решения второй задачи нужно заменить (n mod 2 = 0) на (n mod 2 = 1) и (n mod 3 = 0) на (n mod 7 = 0).


image
(5.6k баллов)
0

Спасибо огромное