Напишите программу которая по табельному номеру рабочего (целому числу от 1 до 10) выдает...

0 голосов
109 просмотров

Напишите программу которая по табельному номеру рабочего (целому числу от 1 до 10) выдает в качестве результата название его профессии и разряд (например: токарь, 2 разряд).


Информатика (24 баллов) | 109 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
n: integer;

begin
read(n);
case n of
1: writeln('Сварщик, 1 разряд');
2: writeln('Токарь, 2 разряд');
3: writeln('Автоклавщик,3 разряд');
4: writeln('Дробильщик, 4 разряд');
5: writeln('Жаровщик, 5 разряд');
6: writeln('Интонировщик,6 разряд');
7: writeln('Машинисит протектороного агрегата, 7 разряд');
8: writeln('Помощник механика, 8 разряд');
9: writeln('ТУТ САМ НАЙДЕШЬ');
10: writeln('И ТУТ ТОЖЕ');
else writeln('Такого номера нет');
end;
end.

(1.8k баллов)
0

И как эту программу завершить?

0

Поправила

0

Да, поправили. Теперь "цикл" выполнится один раз, т.е. он не нужен.

0

Теперь все хорошо!