Написать программу в ** языке Pascal. По желанию помочь понять, что в моем коде не так:...

0 голосов
50 просмотров

Написать программу в на языке Pascal. По желанию помочь понять, что в моем коде не так: var a, b, c, s, k, y:real;
begin
writeln('Введите числа a,b,c');
readln(a, b, c);
s :=(sqrt(a + b*b*b*b*b))/(3 * c);
k :=s - (sqrt(abs(a * b * c)));
y :=(s + k) - (s/(b*c));
writeln('y= ',y);
end.
(человека, который поможет отмечу лучшим)


image

Информатика (113 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

При таком наборе данных при вычислении значения s получается корень квадратный из отрицательного числа -29. Поэтому программа и выдает сообщение : Не число.
Набор данных некорректен.

(13.9k баллов)
0

Ошибка условии?

0

в*

0

Либо в условии, либо в данных для проверки