Очень мало времени Составить программу решения уравнения a*x+b=c Pascal abc net...

0 голосов
57 просмотров

Очень мало времени

Составить программу решения уравнения
a*x+b=c
Pascal abc net

Пожалуйста!! Проверьте у меня один шанс!!!!



Информатика (48 баллов) | 57 просмотров
0

Ограничения на значения a,b,c есть? Надо проверять случаи равенства нулю каждого из них или какой-то их части? Или считать, что a никогда нулем быть не может?

Дан 1 ответ
0 голосов

Требуется найти Х, поэтому перепишем уравнение так:
x=(c-b)/a. Теперь код программы может быть таким:

var a,b,c:real;
begin
  writeln('Введите a,b,c');
  readln(a,b,c);
  if a<>0 then writeln('x = ', (c-b)/a)
    else
  writeln('деление на 0');
end.

(13.9k баллов)
0

Если a=b=c=0, то нет деления на 0, а х - любое )))