Написать программу, которая в массиве случйных чисел С[1..5,1..5] меняет местами значения...

0 голосов
48 просмотров

Написать программу, которая в массиве случйных чисел С[1..5,1..5] меняет местами значения элементов главной и вспомогательнй диагонали


Информатика (21 баллов) | 48 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

uses crt;

var C:array[1..5,1..5] of integer;

i,j,temp:integer;

 

begin

   randomize();

   for i:=1 to 5 do

      for j:=1 to 5 do

         C[i,j]:=random(1000);

   for i:=1 to 5 do begin

      t:=C[i,i];

      C[i,i]:=C[i,6-i];

      C[i,6-i]:=t;

   end

end.

(148k баллов)
0 голосов

program pr;
uses crt;
Var i,j,b:integer;
C:array[1..5, 1..5] of integer;
Begin
for i:=1 to 5 do Begin
Writeln;
    for j:=1 to 5 do Begin C[i,j]:=random(100); Write(C[i,j],'|');  end;
     end;
for i:=1 to 5 do
     Begin
           b:=C[i,i];
           C[i,i]:=C[i,6-i];
           C[i,6-i]:=b;
      end;
Writeln;
      
for i:=1 to 5 do Begin
Writeln;
    for j:=1 to 5 do  Write(C[i,j],'|');
     end;
      

readln;
end.

(3.2k баллов)