Pascal!Даю 30 балов! Написать программу,помогите Дано 4-х значное число<вычислить...

0 голосов
75 просмотров

Pascal!Даю 30 балов!
Написать программу,помогите
Дано 4-х значное число<вычислить произведение его чисел


Информатика (58 баллов) | 75 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var n,m: integer;
begin
  write('число:  ');  readln(n);
  m:=1;
  repeat
    m:=m*(n mod 10);
    n:=n div 10;
  until n=0;  
  writeln('произведение цифр:  ',m);  
end.


(9.7k баллов)
0

until не проходили repeat тоже

0

А while проходили?

0

нет

0

А что из циклов проходили?

0

проходили read(a) div S:=a mod wtite(s) ну эти примеры

0

begin write('число: '); readln(n); m:=(n mod 10); m:=m*((n div 10) mod 10); m:=m*((n div 100) mod 10); m:=m*(n div 1000); writeln('произведение цифр: ',m); end.

0 голосов

Наверное имелось ввиду произведение его цифр, тогда может получиться так:

1. Решение без циклов
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var n,x,p: integer;//n1-кол-во четных, n2-нечетных
begin
  read(n);
  p:=1; 
 
//получаем остаток от деления (единицы) и умножаем на него p
  x:=n mod 10; p:=p*x;
//отбрасываем единицы
  n:=n div 10;
//получаем остаток от деления (десятки) и умножаем на него p
  x:=n mod 10; p:=p*x;
//отбрасываем десятки
  n:=n div 10;
//получаем остаток от деления (сотни) и умножаем на него p
  x:=n mod 10; p:=p*x;
//отбрасываем сотни
  n:=n div 10;
//получаем остаток от деления (тысячи) и умножаем на него p
  x:=n mod 10; p:=p*x;
//отбрасываем тысячи
 n:=n div 10;
///получаем остаток от деления (сотни тысяч) и умножаем на него p
 x:=n mod 10; p:=p*x;
// Теперь в p находится произведение единицы*сотни*тысячи*сотни тысяч

  writeln('Произведение цифр ',p);
end.

2. Решение с циклом

//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var n,x,p: integer;
begin
  readln(n);
  p:=1;
  while n>0 do  begin
  x:=n mod 10; p:=p*x;
  n:=n div 10;
  end;
  writeln('Произведение цифр ',p);
end.













(13.9k баллов)
0

Moжно и этот

0

спасибо,прости,мне алгебра и геометрия легко даётся,химия и информатика не даётся вообще..

0

Бывае, держитесь!

0

а вместо 10 надо 1000 писать?

0

И последнее пожалуйста.. writeln('Произведение цифр ',p);xnj nenn,

0

что тут?

0

Алгоритм работает так, что на каждом шаге он отсекает

0

единицы, затем десятки, затем сотни ... Мы все время получаем о получаем остаток от деления на 10

0

а то что надо произведение 4-х значного числа это ничего не значит?

0

нашли геморой на свою попу:D