напишите программу для паскаля. условие: обменять значения двух переменных, используя...

0 голосов
50 просмотров

напишите программу для паскаля.

условие: обменять значения двух переменных, используя третью(буферную) переменную


Информатика (224 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

var

  a, b, buf:real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  buf := a;

  a := b;

  b := buf;

  writeln('a = ', a);

  writeln('b = ', b);

end.

 

 

// без буферной переменной

var

  a, b:real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  a := a + b;

  b := a - b;

  a := a - b;

  writeln('a = ', a);

  writeln('b = ', b);

end.

 

(3.1k баллов)