Решите пожалуйста через программу Кумир

0 голосов
50 просмотров

Решите пожалуйста через программу Кумир


image

Информатика (14 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

К сожалению я не знаю такой программы, но использую цикл For, укажи For a:=1 to 101 do (sum:=sum+1);

Я могу помочь больше, скинь основные команды. Но я думаю, что там есть такой цикл.

(581 баллов)
0

нет

0

ну там если,вывод,ввод,кц,нц,если,то

0

Давайте так, что именно вам не понятно? Такую программу очень просто написать, достаточно знать циклы, вы знаете что такое цикл и как его составить в Кумире?

0

мне вообще там ничего не понятно

0

Но как же так? Изучите основы и циклы, тогда вы сможете написать программу, что вы делали на уроках? (Или как вы изучаете программирование)

0

просто я не понимаю

0

даже не понимаю,зачем это вообще нужно

0

Программирование? В основном сейчас технологии землян связаны с этим нелёгким делом, или лёгким... Впрочем, это язык машин, это письмо-приказ для машины, и она с радостью его выполняет, если всё было верно написано.

Попробуйте изучить Кумир на YouTube для основного понятия, если хотите. 
Вот к примеру так должна выглядеть программа, но написана как образец:

Начать

От 1 до 101 делай
S присвоить значение S+1

Выведи (S)

Таким образом программа сложит всё начинаю с 1 до 101= 5151

0

Вот пример на Pascal ABC NET:

 var
 a:integer;
 s:integer;
 
 begin
 
 s:=1;
 
 for a:=2 to 3 do
 begin
  s:= s + a;
  
  writeln(a, '+', s, ' ', s+a);
  end;
  
  writeln(s);
  
  end.

0

Точнее:

 var
 a:integer;
 s:integer;
 
 begin
 
 s:=1;
 
 for a:=2 to 101 do
 begin
  s:= s + a;
  
  writeln(a, '+', s, ' ', s+a);
  end;
  
  writeln(s);
  
  end.