Написать программу, которая, решает квадратное уравнение |ax+b|=cx+d. ** вход вы...

0 голосов
44 просмотров

Написать программу, которая, решает квадратное уравнение |ax+b|=cx+d. На вход вы получаете
a,b,c,d. На выходе должно быть, либо 2 корня если таких 2, либо 1, либо надпись что корней нет


Информатика | 44 просмотров
0

На Паскале пойдет?

0

не пойму только, почему ты его называешь квадратным - условие точно правильно записано????

0

жди

Дано ответов: 2
0 голосов
Правильный ответ

Program rtr1;Uses crt;Var a,b,c,d,di,f,x1,x2:real;Begin Clrscr; Readln(a,b,c,d); f:=0; di:=sqr(2*a*b-2*c*d)-4*(a*a-c*c)*(b*b-d*d); if di>0 then  begin   x1:=((2*c*d-2*a*b)+sqrt(di))/(2*a*a-2*c*c);   x2:=((2*c*d-2*a*b)-sqrt(di))/(2*a*a-2*c*c);   if (abs(a*x1+b)=c*x1+d) then f:=f+1;   if (abs(a*x2+b)=c*x2+d) then f:=f+1;  end else if d=0 then              begin               x1:=(2*c*d-2*a*b)/(2*a);               if (abs(a*x1+b)=c*x1+d)then f:=f+1;             end             else writeln('Корней нет'); Writeln('Уравнение имеет ',f,' корней ');End.


Скачать вложение Текст (TXT)
(5.6k баллов)
0 голосов

Думаю тебе нужно ещё подождать 

(50 баллов)
0

При вводе 2 1 2 1 Ваша программа выдает сообщение, что нет корней, хотя, на самом деле, будет множество решений   x>= - 0.5 

0

при данном условии коэффициенты a,b,c,d должны быть различны 

0

Пользователь может вводить что угодно, на то он и пользователь.  Однако, программа не проходит и на другом тесте.  При вводе 1  3 - 2  5  программа выдает, что нет корней,  однако корень есть  x = 0.66....