Написать программу в паскале для определения сдачи после покупки в магазине товара:...

0 голосов
62 просмотров

Написать программу в паскале для определения сдачи после покупки в магазине товара: перчаток стоимостью а руб., портфеля стоимостью b руб., галстука стоимостью с руб. Исходная сумма, выделенная на покупку d руб. В случае нехватки денег соответствующее сообщение.


Информатика (12 баллов) | 62 просмотров
Дан 1 ответ
0 голосов

Var a,b,c,d : Integer;
Begin
  Write('a b c d  ? ');
  Readln(a,b,c,d);
  If a+b+c>d then Writeln('не хватает денег') else Writeln('Сдача (руб.): ',d-(a+b+c));
end.

(5.1k баллов)
0

не совсем точно но спасибо

0

Все достаточно точно. Укажите, что именно по Вашем "не точно"?

0

где команды writeln например writeln('Введите стоимость перчатки') дальше readln (a) и кстати я сам уже всё сделал

0

А Вы присмотритесь - все это есть. А поменять выводимый текст - много ума не надо.