В паскале.нет вычислить Z

0 голосов
25 просмотров

В паскале.нет вычислить Z


image
image

Информатика (111 баллов) | 25 просмотров
0

напишите программу полностью

Дан 1 ответ
0 голосов
Правильный ответ

Var x,y,z,a1,a2,c:real;
begin
write('x='); readln(x);
if x<3<br> then y:=abs(x)+2
 else if x=3 then begin write('a1='); readln(a1); y:=x*x-a1; end
                  else if x<10 then begin write('c='); readln(c); y:=x-c; end<br>                                     else begin write('a2='); readln(a2); y:=a2*a2; end;
z:=y*y+x*x;
writeln('z=',z);
end.

Пример:
x=4
c=5
z=17

(194k баллов)