Написать программу: вводятся число до тех пор пока не введен 5. Найти произведение чисел...

0 голосов
57 просмотров

Написать программу: вводятся число до тех пор пока не введен 5. Найти произведение чисел не равных нулю. Ребята очень срочно


Информатика (49 баллов) | 57 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var prod,temp:real;

begin

   prod:=1;

   repeat

      readln(temp);

      if (temp=5) then break;

      if (temp<>0) then prod := prod * temp;

   until (2*2=5);

   writeln(prod);

end.

(148k баллов)