Напишите программу для PascalABC срочно! Дано 5-значное число. Если оно палиндром, то...

0 голосов
47 просмотров

Напишите программу для PascalABC срочно!
Дано 5-значное число. Если оно палиндром, то вывести 0, если нет-1


Информатика (267 баллов) | 47 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
begin
  var s:=ReadInteger('n=').ToString;
  if s=s.Inverse then Writeln(0) else Writeln(1)
end.

(142k баллов)
0

Возможно это лишнее, но предложенная программа проверяет на "палиндромность" целые числа любой допустимой разрядности, а не только пятизначные.

0 голосов

Var
   i: string;
Begin
  Writeln('Введите число');
  Readln(i);
 if ((i[1]=i[5]) and (i[2]=i[4])) then writeln('0') else writeln('1');
End.

(2.6k баллов)