Напишите программу в паскале. Использование ветвлений. Ввести пять чисел и найти...

0 голосов
75 просмотров

Напишите программу в паскале.
Использование ветвлений.
Ввести пять чисел и найти наибольшее из них.
Пример:
Введите пять чисел:
4 15 9 56 4
Наибольшее число 56


Информатика (1.0k баллов) | 75 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
begin
  Writeln('Наибольшее число ',
    ReadArrInteger('Введите пять чисел:'+NewLine,5).Max)
end.

Тестовое решение:
Введите пять чисел:
 4 15 9 56 4
Наибольшее число 56

(142k баллов)
0 голосов

Program p12;
type tab=array[1..5] of integer;
var t:tab;
i,max:integer;
begin;
for i:=1 to 5 do readln(t[i]);
for i:=1 to 5 do 
if t[i]>max then max:=t[i];
write('Наибольшее число ',max);
end.

(346 баллов)