15 баллов!Нужно составить программу в Паскаль. Если сумма различных целых чисел х, у, z...

0 голосов
43 просмотров
15 баллов!
Нужно составить программу в Паскаль.
Если сумма различных целых чисел х, у, z меньше 30, то заменить меньшее из у и х суммой двух других. В противном случае увеличить все числа на 10

Информатика (365 баллов) | 43 просмотров
0

А что в итоге нужно вывести?

Дан 1 ответ
0 голосов
Правильный ответ

Var x,y,z:integer;
begin
write('x='); readln(x);
write('y='); readln(y);
write('z='); readln(z);
if x+y+x<30<br>  then  if x  else begin x:=x+10; y:=y+10; z:=z+10 end;
writeln('x=',x,'  y=',y,'  z=',z);
end.

Пример:
x=7
y=12
z=9
x=19  y=12  z=9

(194k баллов)