Написать программу, которая печатает значение логического выражения (TRUE или FALSE)в...

0 голосов
121 просмотров

Написать программу, которая печатает значение логического выражения (TRUE или FALSE)в Паскале:Первая и последняя цифры трехзначного числа равны.


Информатика (23 баллов) | 121 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a: integer;
begin
  readln(a);
  writeln(a mod 10 = a div 100);
end.

(5.1k баллов)
0

Вводится трехзначное число, нажимается ENTER, программа пишет true или false.

0

пардон, не туда(

0 голосов

Var
a: integer;
begin
readln(a);
if a mod 10 = a div 100 then
writeln('TRUE')
else
writeln('FALSE');
end.

(15.5k баллов)
0

хотя не знаю будет ли работать в ABC

0

сделайте проще, поставьте readln; перед end.

0

Работает и в ABC, и в ABC.NET

0

все

0

да все работает, я имел в виду сочетание клавишь alt+F5 (показать экран вывода)

0

; пропустил:D

0

readln помог?

0

не пробовал.просто сам все распечатал.а до этого тупо скопировал

0

А скопированный код не работает разве?

0

не знаю.но верно не верно не показывало