Напишите программу для заштрихованной области графика ** языке Pascal var x,y: real;...

0 голосов
54 просмотров

Напишите программу для заштрихованной области графика на языке Pascal
var x,y: real;
begin
read (x,y);
if .........


image

Информатика (162 баллов) | 54 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  x,y:real;
  b:boolean;
begin
  read(x,y);
  if sqr(x)+sqr(y)<=1 then<br>    if x<=0 then b:=((y>=0) and (y<=-x) or (y<=x))<br>    else b:=((y<=0) and(y>=-x) or (y>=x))
  else b:=False;
  if b then Writeln('Точка попадает в область или лежит на границе')
  else Writeln('Точка не попадает в область и не лежит на границе')
end.

(142k баллов)