Помогите пожалуйста написать программу (паскаль) 10 класс дам 20 баллов

0 голосов
64 просмотров

Помогите пожалуйста написать программу
(паскаль) 10 класс
дам 20 баллов


image

Информатика (1.0k баллов) | 64 просмотров
Дан 1 ответ
0 голосов

Program pr;
uses crt;

Var n,i, k1,k2:integer;
mas: array[1..1000] of integer;

Begin
randomize;
Writeln('Введите размер массива не больше 1000');
readln(n);

k1:=0; 
k2:=0;

for i:=1 to n do
    Begin
      mas[i]:=Random(220+1)-70;
       if (mas[i]<0) <br>         then k1:=k1+1;
      if (mas[i]>0)
        then k2:=k2+1;
    end;

Writeln('Сформированный массив:');
for i:=1 to n do
  Begin
      Write(mas[i],' ');
   end;


Writeln();
Writeln('Количество отрицательных = ', k1);
Writeln('Количество положительных = ', k2);

readln;
end.

(3.2k баллов)