Написать программу ** паскале: найти разность между К и суммой всех элементов массива с...

0 голосов
47 просмотров

Написать программу на паскале: найти разность между К и суммой всех элементов массива с нечетными индексами


Информатика (19 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Желательно в задании уточнять тип массива (целый, вещественный ) и споособ его генерации(ввод с клавиатуры, генератор случайных чисел).

 

В данной программе массив получен с помощью  генератора случайных чисел 

 

  

Program raznost;

Uses Crt;

const n=100; {максимальный размер массива}

var a:array[1..n] of  integer; 

 

       i,m:integer;

       k,s,rez:longint;

begin

     clrscr;

     write('Введите К: ');

     readln(k);

     write('Введите размер массива <100: ');</p>

     readln(m);

 

 

     randomize; 

     write('Исходный массив:')

 

    s:=0;

     for i:=1 to m do

          begin

               a[i]:=random(50)+25;   

 

               write(i:3);   

 

               if  (i mod 2)<>0 then s:=s+a[i];

 

           end;

     writeln;

     rez:=k-s;       

     writeln('Разность между K и суммой всех элементов массива с нечетными индексами=',rez);

     readkey;

end. 

 

 

(2.4k баллов)