Помогите написать программу ** паскале абс Дано трехзначное число. Найдите его палиндром...

0 голосов
51 просмотров

Помогите написать программу на паскале абс
Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром — это натуральное число, которое читается слева направо и справа налево одинаково. Иначе говоря, отличается симметрией записи (расположения цифр), причём число знаков может быть как чётным, так и нечётным. Например, 165 его палиндром 561.


Информатика (35 баллов) | 51 просмотров
Дан 1 ответ
0 голосов
Program palidron;

var
   a, b, c, x, d: integer;

begin
      writeln('Число:');
       readln(a);
       b:= a mod 10;
       c:= (( a div 10) mod 10);
       x:= (( a div 10) div 10);
       d:= 100*b+10*c+x;
       writeln('Палиндром: ',b,c,x);
       writeln('Произведение числа и палиндрома: ',d*a);
end.
(27 баллов)