Напишите программу, которая вводит натуральное число N и выводит ** экран N...

0 голосов
180 просмотров

Напишите программу, которая вводит натуральное число N и выводит на экран N псевдослучайных чисел. Запустите её несколько раз, объясните результаты опыта.


Информатика (403 баллов) | 180 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  SeqRandom(ReadInteger('n='),1,99).Println
end.

Тестовое решение:
n= 30
8 39 37 3 4 57 33 31 44 12 32 80 14 19 73 64 81 82 36 6 48 12 84 81 6 66 36 51 40 69

(142k баллов)
0 голосов

Var n, i: integer;
begin
//включаем рандом
randomize;
//Вводим N
readln(n);
//генерируем N случайных чисел до 100. 
for i:=1 to n do
    begin
    n:=random(100);
//Выводим эти числа
    write (n, ' ');
    end;
    writeln;
end.

(1.8k баллов)