Составить программу,которая формирует список L, включив в него по одному разу...

0 голосов
103 просмотров

Составить программу,которая формирует список L, включив в него по одному разу элементы,которые входят одновременно в оба списка L1 и L2.
Pascal abc.net


Информатика (475 баллов) | 103 просмотров
0

Именно список? Т.е. предлагается создать списочную структуру, определить процедуры для работы с ней.... или тут "список" - это просто синоним слова "набор чисел"? или не чисел... Вы не указали, какой тип должны иметь элементы, может, они слова или отдельные символы, а не числа.

0

2 вариант,давайте с числами

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.0, сборка 1088
begin
  var L1:=new List;
  L1.AddRange(SeqRandom(15,-20,20));
  Writeln('Список L1'); Writeln(L1);
  var L2:=new List;
  L2.AddRange(SeqRandom(10,-5,40));
  Writeln('Список L2'); Writeln(L2);
  var L:=new List;
  L.AddRange(L1.Intersect(L2).Distinct);
  Writeln('Список L'); Writeln(L);
end.

Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]

(142k баллов)