Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит...

0 голосов
511 просмотров

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое


Информатика (15 баллов) | 511 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

const

  n = 10;

var

  a, summ, i:integer;

begin

  randomize;

  summ := 0;

  for i := 1 to n do

  begin

    a := random(20) + 1;

    summ := summ + a;

    write(a, ' ');

  end;

  writeln;

  writeln('Среднее арифметическое этих чисел ',summ / n);

end.

 

(3.1k баллов)
0 голосов

program random_1;
var
x,sum,i:integer;
begin
randomize;
writeln('Ряд случайных чисел: ');
for i:=1 to 10 do begin
                        x:=random(20)+1;
                        sum:=sum+x;
                        if i<>10 then write(x,', ')
                                    else writeln(x,'.');
                        end;
writeln('Среднее арифметическое этих чисел ',sum/10);
end.

(208 баллов)