Напишите программу, которая вводит четырехзначное число и "вырезает" из него первую и...

0 голосов
234 просмотров

Напишите программу, которая вводит четырехзначное число и "вырезает" из него первую и последнюю цифры, например, из 1234 должно получиться 23.


Информатика (45 баллов) | 234 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Сначала отбрасываем последнюю цифру с помощью div 10.
Затем берем остаток от деления на 100, чтобы избавится от первой цифры
var n: integer;
begin
  read(n);
  writeln(n div 10 mod 100)
end.

(13.3k баллов)