Помогите написать программу! очень срочнооо..

0 голосов
32 просмотров

Помогите написать программу! очень срочнооо..


image

Информатика (51 баллов) | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var  
x1,x2,y1,y2,P,S,a,b:integer;
Begin  
Write('Введите X1,Y1,X2,Y2 ');  
Readln(x1,y1,x2,y2);  
a:=x1-x2;  
b:=y1-y2;  
if a<0 then a:=-a;  </span>
if b<0 then b:=-b;  </span>
p:=(a+b)*2;  
s:=(x1-x2)*(y1-y2);  
if s<0 then s:=-s;  </span>
Write('S = ',s,' | P = ',p);
End.  

(2.6k баллов)