Паскаль.Написать программу вычисления значений функций Y=1/x+2 с шагом 0,1.Значения...

0 голосов
84 просмотров

Паскаль.Написать программу вычисления значений функций Y=1/x+2 с шагом 0,1.Значения аргумента берутся из [-1;1].Программа должна работать!Нерабочие не писать.


image

Информатика (95 баллов) | 84 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

var

  i:integer;

begin

  for i := -10 to 10 do

    if i <> 0 then

      writeln('x = ', i / 10 :6:2, '    y = ', 10 / i + 2 :0:2)

    else

      writeln('x =   0.00    y не определен');

end.

(3.1k баллов)
0 голосов

var
x,y:real;
begin
x:=-1;
while x<=1 do begin<br>if x=0 then
writeln('x=0 net resheniy')
else begin
y:=1/x+2;
writeln('x=', x:0:2, ' y=',y:0:2);
end;
x:=x+0.1;
end;
end.

(3.4k баллов)