Написать программу вычисления факториала с использованием рекурсивной подпрограммы

0 голосов
79 просмотров

Написать программу вычисления факториала с использованием рекурсивной подпрограммы


Информатика (17 баллов) | 79 просмотров
0

Процедуры или функции?

Дан 1 ответ
0 голосов

Var n:integer;
Function Factorial(n : Integer) : Integer;
Begin If n = 1 then   Factorial := 1
Else  Factorial := n*Factorial(n-1);
End;
begin
readln(n);
write(factorial(n));
end.   

(346 баллов)