(Написать программу) Спортсмен в 1 день пробежал 10 км, каждый день он увеличивал пробег...

0 голосов
41 просмотров

(Написать программу) Спортсмен в 1 день пробежал 10 км, каждый день он увеличивал пробег на 10%.В какой день он пробежит 20 км?


Информатика (12 баллов) | 41 просмотров
Дан 1 ответ
0 голосов

Program Sport;
Var
    s: Real;
    day: Integer;
Begin
    
    day := 1;
    s := 10;
    
    while s < 20 do
    begin
        day := day + 1;
        s := s + (s/100)*10;
    end;
    
    WriteLn(day);
    
    ReadLn;
End.

(333 баллов)