С++Так что бы программа просила в вести значение ** русском 1.Напишите программу, которая...

0 голосов
267 просмотров

С++
Так что бы программа просила в вести значение на русском
1.Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры).
2.Найти среднее арифметическое всех целых чисел от 1 до 1000.
3.Пользователь вводит две границы диапазона, вывести на экран все числа из этого диапазона. Предусмотреть, чтобы пользователь мог вводить границы диапазона в произвольном порядке.
вывести все четные числа из диапазона.
вывести все нечетные числа из диапазона.
вывести все числа, кратные семи
4.Пользователь с клавиатуры вводит числа. Посчитать их сумму и вывести на экран, как только пользователь введет ноль.


Информатика (32 баллов) | 267 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1.
#include
using namespace std;
void main()
{
    //задаём русский язык для консоли
    setlocale(LC_ALL, "Russian");
    long sum = 0;
    int a;
    cout << "Введите a" << endl;<br>    cin >> a;
    if (a > 500)
    {
        cout << "а > 500" << endl;<br>    }
    else
    {
        sum = (500 * 501 / 2) - ((a - 1) * a ) / 2;
        cout << sum;<br>    }
}
2.
#include
using namespace std;
void main()
{
    //задаём русский язык для консоли
    setlocale(LC_ALL, "Russian");
    double average = (1 + 1000) / 2.;
    cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;<br>}
3
#include
using namespace std;
void main()
{
    //задаём русский язык для консоли
    setlocale(LC_ALL, "Russian");
    int a = 0, b = 0;
    cout << "Введите границы диапазона" << endl;<br>    cin >> a >> b;
    cout << "Все числа:" << endl;<br>    if (a <= b)<br>    {
        for (int i = a; i <= b; i++)<br>        {
            cout << i << endl;<br>        }
    }
    else
    {
        for (int i = b; i < a; i++)
        {
            cout << i << endl;<br>        }
    }
    cout << "Чётные числа:" << endl;<br>    if (a <= b)<br>    {
        for (int i = a; i <= b; i++)<br>        {
            if (i % 2 == 0)
            {
                cout << i << endl;<br>            }
        }
    }
    else
    {
        for (int i = b; i < a; i++)
        {
            if (i % 2 == 0)
            {
                cout << i << endl;<br>            }
        }
    }
    cout << "Нечётные числа:" << endl;<br>    if (a <= b)<br>    {
        for (int i = a; i <= b; i++)<br>        {
            if (i % 2 != 0)
            {
                cout << i << endl;<br>            }
        }
    }
    else
    {
        for (int i = b; i < a; i++)
        {
            if (i % 2 != 0)
            {
                cout << i << endl;<br>            }
        }
    }
    cout << "Числа, кратные 7:" << endl;<br>    if (a <= b)<br>    {
        for (int i = a; i <= b; i++)<br>        {
            if (i % 7 == 0)
            {
                cout << i << endl;<br>            }
        }
    }
    else
    {
        for (int i = b; i < a; i++)
        {
            if (i % 7 == 0)
            {
                cout << i << endl;<br>            }
        }
    }
}
4.
#include
using namespace std;
void main()
{
    //задаём русский язык для консоли
    setlocale(LC_ALL, "Russian");
    int a = 0, sum = 0;
    cout << "Введите числа" << endl;<br>    while (true)
    {
        cin >> a;
        if (a == 0)
        {
            break;
        }
        sum += a;
    }
    cout << "Сумма =" << sum << endl;<br>}

 







(812 баллов)
0

2 не правильно