Даны два набора чисел (5,6,1,2,3) и (5,8,6,0,3) написать программу , которая подсчитывает...

0 голосов
36 просмотров

Даны два набора чисел (5,6,1,2,3) и (5,8,6,0,3) написать программу , которая подсчитывает количесво чисел, которые совпадают в обоих наборах, и записывает на их место нули.решение с объяснениями пож)


Информатика (51 баллов) | 36 просмотров
Дано ответов: 2
0 голосов

GalyaZelenina, на каком языке нужен код?

и в задаче не очень понятное условие: совпадают на позициях? или вообще если есть совпадения?

могу вам помочь на си или на питоне

(72 баллов)
0 голосов

Uses crt;
const mn1: array[1..5] of byte =(5,6,1,2,3); {Объявляем наши наборы}
const mn2: array[1..5] of byte =(5,8,6,0,3); {Объявляем наши наборы}

var i,c,n:integer;

begin
clrscr;
  write('Набор1 до обработки:');  
  for i:=1 to 5 do write(mn1[i]:3);  {Выводим  на экран набор 1} 
writeln;
writeln;

 write(' Набор2 до обработки: :'); 
  for i:=1 to 5 do write(mn2[i]:3);  {Выводим  на экран набор 2}

writeln;
 writeln; 

n:=1; c:=0;
  while (n<=5) do         {В цикле сравниваем n-й элемент набора1 с}<br>  Begin                           {каждым   элемент набора2 } 
for i:=1 to 5 do begin
  if (mn1[n]=mn2[i]) then  
begin
  c:=c+1;    {Если нашли совпадение до увеличиваем кол-во совпадающих пар чисел}
  mn1[n]:=0;          {И записываем на их место нули}
mn2[i]:=0;

break;  {переходим к след элементу набора1}
end;
  end;


Inc(n);
End;

 {Выводим результаты обработки}

write('Количество совпадающих пар чисел:',c);

writeln;
write(' Набор1 после обработки :');
for i:=1 to 5 do write(mn1[i]:3);
writeln;
writeln;

  write(' Набор2 после обработки :');
for i:=1 to 5 do write(mn2[i]:3);
  readkey; {пауза до нажатия на любую клавишу}
end.

(2.4k баллов)