Разработайте алгоритм и напишите программу, которая вычисляет стоимость покупки с учетом...

0 голосов
133 просмотров

Разработайте алгоритм и напишите программу, которая вычисляет стоимость покупки с учетом скидки. Скидка в 10% предоставляется в том случае, если стоимость покупки больше 1000 руб.


Информатика (12 баллов) | 133 просмотров
Дано ответов: 2
0 голосов

блок-схема во вложении..................


image
(3.4k баллов)
0 голосов

uses crt;
var a,s:real;
begin
write('Введите общую цену товаров, которую вы хотите купить: ');
readln(a);
if a>1000 then s:=a-0.1*a
else s:=a;
writeln('Стоимость покупки составляет ',s,' рублей.');
end.

Это программа. Суть в том, что если цена больше 1000 рублей,  то стоимость - это цена минус 1/10 от это цены, иначе цена совпадает со стоимостью.

(559 баллов)