Помогите пожалуйста написать программу ** Pascal.Это очень срочно!!! Найдите и выведите...

0 голосов
29 просмотров

Помогите пожалуйста написать программу на Pascal.Это очень срочно!!!
Найдите и выведите на экран самую большую и самую маленькую цифру в трехзначном числе введенного с клавиатуры.
Очень желательно с объяснениями, т.к. в домашнем задании очень много однотипных задач. И просьба без "Введите число" и т.д.Заранее спасибо.


Информатика | 29 просмотров
0

Только не бросайте!!!Мне уже два человека хотели ответить, но бросили. Это правда очень нужно.

Дан 1 ответ
0 голосов
Правильный ответ

Var
    N, a1, a2, a3, min, max: integer;
begin
    readln(N);
    N := abs(N);
    a1 := N mod 10; //в а1 хранится разряд единиц введённого числа
    N := N div 10;     //"стираем" в N последнюю цифру
    a2 := N mod 10; //в а2 хранится рязряд десятков числа N
    N := N div 10;
    a3 := N mod 10; //в а3 хранится рязряд сотен числа N
    //-------------------------
//поиск минимума из цифр. в переменной мин
//хранится наименьшее число на данном шаге.
    min := a1;          
    if a2 < min then
        min := a2;
    if a3 < min then
        min := a3;
   //---------------------------
//поиск максимума
    max := a1;
    if a2 > max then
        max := a2;
    if a3 > max then
        max := a3;
    //--------------------------
    writeln('min - ', min, ' max - ', max);
end.

(1.4k баллов)
0

Я имею ввиду какой ответ должен быть на тесте -123

0

ой, не заметил 

0

но я не понимаю, от куда вы взяли число 0

0

в числе -123 нет цифры 0

0

Я о том же

0

-123
min - -2 max - 0

0

Это то,что мне он пишет.Я пытаюсь найти проблему у себя, но проблем не вижу.

0

Поытаюсь поискать дальше.

0

Не знаю, в чём может быть проблема.  У меня всё работает правильно. Может вы смотрите на вывод другого теста? Если вы пишете на Pascal ABC, я бы посоветовал закрыть компилятор, открыть и вставить туда программу заново. Он иногда делает что-то неописуемое

0

Вы умеете делать пошаговую отладку?