Даны 6 чисел. найти максимальное четное число. написать программу с помощью Pascal и...

0 голосов
125 просмотров

Даны 6 чисел. найти максимальное четное число.

написать программу с помощью Pascal и используя цикл repeat....until

помогите, пожалуйста!


Информатика (487 баллов) | 125 просмотров
Дан 1 ответ
0 голосов

var
  a, max, i: integer;
begin
  repeat
    readln(a);
    if(a > max) and (a mod 2 = 0) then max := a;
    inc(i);
  until(i = 6);
  writeln('Макс. четное число: ', max);
end.

(1.1k баллов)