Составить программу,которая выводит ** экран коды введенных слов,затем меняет каждый...

0 голосов
70 просмотров

Составить программу,которая выводит на экран коды введенных слов,затем меняет каждый символ с соседним и выводит полученный текст на экран


Информатика (94 баллов) | 70 просмотров
Дан 1 ответ
0 голосов
uses crt;
var c:char;
begin clrscr;
write('Введите символ ');
readln(c);
case c of '0'..'9':write('Это десятичная цифра, ее код ',ord(c)); 'A'..'Z':write('Это прописная латинская буква, ее код ',ord(c)); 'a'..'z':write('Это строчная латинская буква, ее код ',ord(c));
'+','-','*':write('Это знак арифметического действия, его код ',ord(c)); //убрал знак /, он в спец. символах ';','<','=','>','?','[',']','{','}','\','/':write('Это служебный символ, его код ',ord(c)); else write('Символ не входит в указанный список') end; readln end.
(70 баллов)
0

а как сделать без графического редактора?

0

есть более простой способ?

0

другой способ я незнаю