Даны две строковые величины. Написать программу подсчета букв 'в' в меньшей по длине...

0 голосов
51 просмотров

Даны две строковые величины. Написать программу подсчета букв 'в' в меньшей по длине величина. В случае равенства длин напечатать значение количества букв 'в' в каждой строковой величине.


Информатика (14 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Var n, m: integer;s,d:string;
procedure fd (var z:string;t:integer);
var i,k:integer;
begin
for i := 1 to t do begin
if z[i] = 'в' then k:= k +1;end;
writeln(k);end;
Begin
d:='Написать программу подсчета букв "в" в меньшей по длине величина ввв прпрпрп ролроллолшл нг';
s:='В случае равенства длин напечатать значение количества букв "в" в каждой строковой величине';
n:=length(s);m:=length(d);
if n = m then begin fd(d,m);fd(s,n);end
else if n < m then fd(s,n)
else fd(d,m);End.

(6.5k баллов)