Написать программу по которой машина переставит местами первую и вторую половину...

0 голосов
70 просмотров

Написать программу по которой машина переставит местами первую и вторую половину введенного слова


Информатика (14 баллов) | 70 просмотров
Дан 1 ответ
0 голосов
var   s : string[50];
  i, j, k : word;  
 f : boolean;  
function isSpace(ch : char) : boolean;
begin   isSpace := false;  
if ch = ' ' then isSpace := true;
end;  
begin   f := false;  
   repeat     j := 0;
    writeln('введите строку, состоящую из 2 слов');
    readln(s);    
for i := 1 to length(s) do    
   if isSpace(s[i]) then  
    begin    
     inc(j);      
   k := i;       end;
     if j =1 then f := true;
    until f;    
write(copy(s, k + 1, length(s)), ' ', copy(s, 1, k - 1)); 
end.
недавно такую писала :)
(1.1k баллов)
0

зачем вводить строку из 2 слов , если нужно менять местами части одного слова ?

0

а как будет выглядить ваш вариант можете написать