Составьте программу по информатике которая удаляет в строке s все пробелы, и заменяет их...

0 голосов
77 просмотров

Составьте программу по информатике которая удаляет в строке s все пробелы, и заменяет их на точки.


Информатика (17 баллов) | 77 просмотров
0

Вы уж определитесь, удаляет или заменяет? Если удаляет, заменять нечего будет уже. А если заменяет, то удалять нельзя.

0

которая заменяет)

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.0, сборка 1088
var
  s:string;
  i,p:integer;
begin
  Write('Введите строку: '); ReadLn(s);
  for i:=1 to Length(s) do
    if s[i]=' ' then s[i]:='.';
  WriteLn('Результат:      ',s)
end.
 
Тестовое решение:
Введите строку: Это дело такое - тестировать   программы   !
Результат:      Это.дело.такое.-.тестировать...программы...!

(142k баллов)
0

огромное спасибо)

0

Пожалуйста. А для "спасибо", чтобы не писать, тут синенькая кнопочка. И звездочки - для размеров "спасибо" )))