Напишите программу, которая сортирует элементы массива по возрастанию последней цифры...

0 голосов
800 просмотров

Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одной строке элементы массива, отсортированного в порядке возрастания последней цифры в десятичной записи чисел, разделив их пробелами. Числа, у которых последняя цифра одинаковая, должны быть выведены в том же порядке, в котором они стояли в исходной последовательности.

Примеры
входные данные
6
219 234 890 81 73 96
выходные данные
890 81 73 234 96 219


Информатика (73 баллов) | 800 просмотров
Дан 1 ответ
0 голосов

Uses crt;var c,i,j,n:integer;a:array [1..1000] of integer;begin clrscr;read(n);for i:=1 to n doread(a[i]);for i:=1 to n dofor j:=1 to n-1 doif (a[j] mod 10) > (a[j+1] mod 10) then beginc:=a[j];a[j]:=a[j+1];a[j+1]:=cend;for i:=1 to n dowrite(a[i],' ')end.


Скачать вложение Текст (TXT)
(4.2k баллов)