Напишите программу, которая вводит два целых числа и находит их произведение, не...

0 голосов
211 просмотров

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.

Входные данные-(Входная строка содержит два целых числа.) Выходные данные-(Программа должна вывести произведение введённых чисел.)

Примеры входные данные-(6,12) выходные данные-(72) РЕШИТЬ В ПАСКАЛЬ АБЦ


Информатика | 211 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
a,b,x,y,z:integer;
 begin
writeln('Введите первое число');
readln(a);
writeln('Введите второе число');
readln(b);
z:=b;
if b<0 then z:=-b; <br>for y:=1 to z do  begin
  x:=x+a;
  end;
if b<0 then x:=-x; <br>writeln('Произведение чисел = ',x);
end.

Проверка по входным данным на фото


image
(8.9k баллов)