Написать программу,...

0 голосов
33 просмотров

Написать программу, вычисляющуюсуммуисреднееарифметическоепоследовательностиположительныхчисел, которыевводятсясклавиатуры.

вид экрана:

Введите числа. Для завершения последовательности нажмите ноль.

45 23 15 0

введено чисел:3

сумма чисел:83

Среднее арифметическое:27.67


Информатика (36 баллов) | 33 просмотров
Дан 1 ответ
0 голосов

 

 

 

В задании не сказанно что числа целые  поэтому тип c: real;

 

 Program SumAndAvg;  

 Uses crt;
var n:integer;
c,s,m:real;
begin
clrscr;
write('Input Numbers:');
n:=0;s:=0;
repeat

read(c);
if (c>0) then
begin
n:=n+1;
s:=s+c;
end;

until (c=0);
writeln('Numbers count =',n);
writeln('Summa =',s:2:2);
writeln('Average Value=',s/n:2:2);
readkey;

end.



(2.4k баллов)