Напишите программу в паскале, вариант 3

0 голосов
25 просмотров

Напишите программу в паскале, вариант 3


image

Информатика (536 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

Procedure TForm1.Button1Click(Sender: TObject);
var
  xn, e, m : Extended;
  xnn : Extended;
begin
  Memo1.Clear;
  xn := StrToFloat(Edit1.Text);
  e := StrToFloat(Edit2.Text);
  m := StrToFloat(Edit3.Text);
  repeat
    xnn := xn;
    xn := (1/3)*(2*xnn + (m/(xnn*xnn)));
    Memo1.Lines.Append('xn = '+floattostr(xn));
  until (Abs(xn-xnn)end;


image
(424 баллов)
0

программа не работает в паскале

0

var
xn, e, m : Double;
xnn : Double;
begin
Write('Введите xn '); Read(xn);
Write('Введите e '); Read(e);
Write('Введите m '); Read(m);
repeat
xnn := xn;
xn := (1/3)*(2*xnn + (m/(xnn*xnn)));
writeln(xn);
until (Abs(xn-xnn)end.

0

спасибо