Напишите программу перевода чисел из двоичной системы счисления в десятичную ** паскале ,...

0 голосов
111 просмотров

Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы.


Информатика (22 баллов) | 111 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a:string[20]; st,b,i:integer;
begin
writeln('Введите двоичное число:');
readln(a);
st:=1; b:=0;
for i:=length(a) downto 1 do
 begin
 if a[i]='1' then b:=b+st;
 st:=2*st;
 end;
writeln(b);
end.

(194k баллов)