Напишите программу ** языке Паскаль для решения следующей задачи: Известно, что Пятачок...

0 голосов
41 просмотров

Напишите программу на языке Паскаль для решения следующей задачи: Известно, что Пятачок собираясь на день рождения Иа, собрал А цветов. Придя на торжество он увидел, что Вини принес цветов в два раза больше чем он, а Сова на пять меньше чем Вини. Немного опоздавший Кролик принес на 3 цветка меньше, чем Пятачок и Вини вместе взятые. Сколько всего цветов принесли на день рождения Иа вместе Сова и Кролик?


Информатика (17 баллов) | 41 просмотров
Дан 1 ответ
0 голосов

{Всего получается A (Пятачок) + A*2 (Винни) + A*2 - 5 (Сова) + A + A*2 - 3 (Кролик) = A*8 - 8 = (A-1)*8 цветов}

var A, S: integer;
begin
read(a);
s := 8*(a-1);
write(s)
end.

(8.5k баллов)